]> eyrie.org Git - kerberos/krb5-strength.git/blobdiff - debian/rules
Finalize changes for 3.3-1
[kerberos/krb5-strength.git] / debian / rules
index 4ea474fb86ed5f03a17dd409d5ce7f56d2c9a859..65c11434f9f3b9851bcf6e8514f685e3b294a218 100755 (executable)
@@ -1,14 +1,23 @@
 #!/usr/bin/make -f
 
+# Add hardening build flags.
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# Enable verbose test output.
+export C_TAP_VERBOSE = 1
+
+PACKAGE := $(shell dh_listpackages)
+
 %:
        dh $@
 
+override_dh_auto_clean:
+       dh_auto_clean -- maintainer-clean
+
 override_dh_auto_configure:
-       dh_auto_configure -- --enable-reduced-depends
+       ./bootstrap
+       dh_auto_configure -- --enable-reduced-depends --with-cracklib
 
 override_dh_auto_install:
        dh_auto_install
-       chmod 644 debian/tmp/usr/lib/kadmind/*.so
-
-override_dh_installchangelogs:
-       dh_installchangelogs NEWS
+       rm debian/$(PACKAGE)/usr/lib/*/krb5/plugins/pwqual/*.la