]> eyrie.org Git - kerberos/krb5-strength.git/blobdiff - Makefile.in
Finalize changes for 3.1-2
[kerberos/krb5-strength.git] / Makefile.in
index d83aec374da619295967c25e9ba6fe2319ec3d31..4a3b535035ab30df29614bd2a27900a7287b8733 100644 (file)
@@ -1,7 +1,7 @@
-# Makefile.in generated by automake 1.14.1 from Makefile.am.
+# Makefile.in generated by automake 1.15 from Makefile.am.
 # @configure_input@
 
-# Copyright (C) 1994-2013 Free Software Foundation, Inc.
+# Copyright (C) 1994-2014 Free Software Foundation, Inc.
 
 # This Makefile.in is free software; the Free Software Foundation
 # gives unlimited permission to copy and/or distribute it,
@@ -17,6 +17,7 @@
 # Automake makefile for krb5-strength.
 #
 # Written by Russ Allbery <eagle@eyrie.org>
+# Copyright 2016 Russ Allbery <eagle@eyrie.org>
 # Copyright 2007, 2009, 2010, 2012, 2013, 2014
 #     The Board of Trustees of the Leland Stanford Junior University
 #
 
 
 VPATH = @srcdir@
-am__is_gnu_make = test -n '$(MAKEFILE_LIST)' && test -n '$(MAKELEVEL)'
+am__is_gnu_make = { \
+  if test -z '$(MAKELEVEL)'; then \
+    false; \
+  elif test -n '$(MAKE_HOST)'; then \
+    true; \
+  elif test -n '$(MAKE_VERSION)' && test -n '$(CURDIR)'; then \
+    true; \
+  else \
+    false; \
+  fi; \
+}
 am__make_running_with_option = \
   case $${target_option-} in \
       ?) ;; \
@@ -95,6 +106,7 @@ check_PROGRAMS = tests/runtests$(EXEEXT) \
        tests/plugin/heimdal-t$(EXEEXT) tests/plugin/mit-t$(EXEEXT) \
        tests/portable/asprintf-t$(EXEEXT) \
        tests/portable/mkstemp-t$(EXEEXT) \
+       tests/portable/reallocarray-t$(EXEEXT) \
        tests/portable/snprintf-t$(EXEEXT) \
        tests/portable/strndup-t$(EXEEXT) \
        tests/util/messages-krb5-t$(EXEEXT) \
@@ -102,25 +114,9 @@ check_PROGRAMS = tests/runtests$(EXEEXT) \
        $(am__EXEEXT_1)
 @EMBEDDED_CRACKLIB_TRUE@am__append_2 = cracklib/packer
 subdir = .
-DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
-       $(top_srcdir)/configure $(am__configure_deps) \
-       $(srcdir)/config.h.in $(top_srcdir)/portable/krb5-extra.c \
-       $(top_srcdir)/portable/snprintf.c \
-       $(top_srcdir)/portable/mkstemp.c \
-       $(top_srcdir)/portable/strndup.c \
-       $(top_srcdir)/portable/asprintf.c $(dist_bin_SCRIPTS) \
-       $(top_srcdir)/build-aux/depcomp $(dist_man_MANS) NEWS README \
-       TODO build-aux/ar-lib build-aux/compile build-aux/config.guess \
-       build-aux/config.sub build-aux/depcomp build-aux/install-sh \
-       build-aux/missing build-aux/ltmain.sh \
-       $(top_srcdir)/build-aux/ar-lib $(top_srcdir)/build-aux/compile \
-       $(top_srcdir)/build-aux/config.guess \
-       $(top_srcdir)/build-aux/config.sub \
-       $(top_srcdir)/build-aux/install-sh \
-       $(top_srcdir)/build-aux/ltmain.sh \
-       $(top_srcdir)/build-aux/missing
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/m4/cracklib.m4 \
+am__aclocal_m4_deps = $(top_srcdir)/m4/cc-flags.m4 \
+       $(top_srcdir)/m4/clang.m4 $(top_srcdir)/m4/cracklib.m4 \
        $(top_srcdir)/m4/krb5-config.m4 $(top_srcdir)/m4/krb5.m4 \
        $(top_srcdir)/m4/lib-depends.m4 $(top_srcdir)/m4/lib-helper.m4 \
        $(top_srcdir)/m4/lib-pathname.m4 $(top_srcdir)/m4/libtool.m4 \
@@ -131,6 +127,8 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/cracklib.m4 \
        $(top_srcdir)/configure.ac
 am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
        $(ACLOCAL_M4)
+DIST_COMMON = $(srcdir)/Makefile.am $(top_srcdir)/configure \
+       $(am__configure_deps) $(dist_bin_SCRIPTS) $(am__DIST_COMMON)
 am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
  configure.lineno config.status.lineno
 mkinstalldirs = $(install_sh) -d
@@ -185,7 +183,8 @@ am__uninstall_files_from_dir = { \
          $(am__cd) "$$dir" && rm -f $$files; }; \
   }
 am__installdirs = "$(DESTDIR)$(moduledir)" "$(DESTDIR)$(bindir)" \
-       "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"
+       "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" \
+       "$(DESTDIR)$(man5dir)"
 LTLIBRARIES = $(module_LTLIBRARIES) $(noinst_LTLIBRARIES)
 cracklib_libcracklib_la_LIBADD =
 am_cracklib_libcracklib_la_OBJECTS =  \
@@ -258,6 +257,13 @@ tests_portable_mkstemp_t_OBJECTS =  \
        $(am_tests_portable_mkstemp_t_OBJECTS)
 tests_portable_mkstemp_t_DEPENDENCIES = tests/tap/libtap.a \
        portable/libportable.la
+am_tests_portable_reallocarray_t_OBJECTS =  \
+       tests/portable/reallocarray-t.$(OBJEXT) \
+       tests/portable/reallocarray.$(OBJEXT)
+tests_portable_reallocarray_t_OBJECTS =  \
+       $(am_tests_portable_reallocarray_t_OBJECTS)
+tests_portable_reallocarray_t_DEPENDENCIES = tests/tap/libtap.a \
+       portable/libportable.la
 am_tests_portable_snprintf_t_OBJECTS =  \
        tests/portable/snprintf-t.$(OBJEXT) \
        tests/portable/snprintf.$(OBJEXT)
@@ -358,6 +364,7 @@ SOURCES = $(tests_tap_libtap_a_SOURCES) $(util_libutil_a_SOURCES) \
        tests/plugin/heimdal-t.c tests/plugin/mit-t.c \
        $(tests_portable_asprintf_t_SOURCES) \
        $(tests_portable_mkstemp_t_SOURCES) \
+       $(tests_portable_reallocarray_t_SOURCES) \
        $(tests_portable_snprintf_t_SOURCES) \
        $(tests_portable_strndup_t_SOURCES) tests/runtests.c \
        tests/util/messages-krb5-t.c tests/util/messages-t.c \
@@ -369,6 +376,7 @@ DIST_SOURCES = $(tests_tap_libtap_a_SOURCES) $(util_libutil_a_SOURCES) \
        tests/plugin/heimdal-t.c tests/plugin/mit-t.c \
        $(tests_portable_asprintf_t_SOURCES) \
        $(tests_portable_mkstemp_t_SOURCES) \
+       $(tests_portable_reallocarray_t_SOURCES) \
        $(tests_portable_snprintf_t_SOURCES) \
        $(tests_portable_strndup_t_SOURCES) tests/runtests.c \
        tests/util/messages-krb5-t.c tests/util/messages-t.c \
@@ -379,8 +387,9 @@ am__can_run_installinfo = \
     *) (install-info --version) >/dev/null 2>&1;; \
   esac
 man1dir = $(mandir)/man1
+man5dir = $(mandir)/man5
 NROFF = nroff
-MANS = $(dist_man_MANS)
+MANS = $(dist_man_MANS) $(man_MANS)
 am__tagged_files = $(HEADERS) $(SOURCES) $(TAGS_FILES) \
        $(LISP)config.h.in
 # Read a list of newline-separated strings from the standard input,
@@ -403,6 +412,24 @@ ETAGS = etags
 CTAGS = ctags
 CSCOPE = cscope
 AM_RECURSIVE_TARGETS = cscope
+am__DIST_COMMON = $(dist_man_MANS) $(srcdir)/Makefile.in \
+       $(srcdir)/config.h.in $(top_srcdir)/build-aux/ar-lib \
+       $(top_srcdir)/build-aux/compile \
+       $(top_srcdir)/build-aux/config.guess \
+       $(top_srcdir)/build-aux/config.sub \
+       $(top_srcdir)/build-aux/depcomp \
+       $(top_srcdir)/build-aux/install-sh \
+       $(top_srcdir)/build-aux/ltmain.sh \
+       $(top_srcdir)/build-aux/missing \
+       $(top_srcdir)/portable/asprintf.c \
+       $(top_srcdir)/portable/krb5-extra.c \
+       $(top_srcdir)/portable/mkstemp.c \
+       $(top_srcdir)/portable/reallocarray.c \
+       $(top_srcdir)/portable/snprintf.c \
+       $(top_srcdir)/portable/strndup.c NEWS README TODO \
+       build-aux/ar-lib build-aux/compile build-aux/config.guess \
+       build-aux/config.sub build-aux/depcomp build-aux/install-sh \
+       build-aux/ltmain.sh build-aux/missing
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
 distdir = $(PACKAGE)-$(VERSION)
 top_distdir = $(distdir)
@@ -459,6 +486,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
 INSTALL_SCRIPT = @INSTALL_SCRIPT@
 INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
 KRB5_CPPFLAGS = @KRB5_CPPFLAGS@
+KRB5_CPPFLAGS_GCC = @KRB5_CPPFLAGS_GCC@
 KRB5_LDFLAGS = @KRB5_LDFLAGS@
 KRB5_LIBS = @KRB5_LIBS@
 LD = @LD@
@@ -469,6 +497,7 @@ LIBTOOL = @LIBTOOL@
 LIPO = @LIPO@
 LN_S = @LN_S@
 LTLIBOBJS = @LTLIBOBJS@
+LT_SYS_LIBRARY_PATH = @LT_SYS_LIBRARY_PATH@
 MAINT = @MAINT@
 MAKEINFO = @MAKEINFO@
 MANIFEST_TOOL = @MANIFEST_TOOL@
@@ -501,6 +530,7 @@ SQLITE_LDFLAGS = @SQLITE_LDFLAGS@
 SQLITE_LIBS = @SQLITE_LIBS@
 STRIP = @STRIP@
 VERSION = @VERSION@
+WARNINGS_CFLAGS = @WARNINGS_CFLAGS@
 abs_builddir = @abs_builddir@
 abs_srcdir = @abs_srcdir@
 abs_top_builddir = @abs_top_builddir@
@@ -545,6 +575,7 @@ pdfdir = @pdfdir@
 prefix = @prefix@
 program_transform_name = @program_transform_name@
 psdir = @psdir@
+runstatedir = @runstatedir@
 sbindir = @sbindir@
 sharedstatedir = @sharedstatedir@
 srcdir = @srcdir@
@@ -554,19 +585,21 @@ top_build_prefix = @top_build_prefix@
 top_builddir = @top_builddir@
 top_srcdir = @top_srcdir@
 ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = .gitignore LICENSE autogen cracklib/HISTORY cracklib/LICENCE  \
-       cracklib/README cracklib/genrules.pl cracklib/mkdict tests/HOWTO   \
-       tests/TESTS tests/data/krb5.conf tests/data/make-krb5-conf         \
-       tests/data/passwords tests/data/perl.conf tests/data/perlcriticrc  \
-       tests/data/perltidyrc tests/data/valgrind.supp tests/data/wordlist \
-       tests/data/wordlist.cdb tests/data/wordlist.sqlite                 \
-       tests/docs/pod-spelling-t tests/docs/pod-t tests/perl/critic-t     \
-       tests/perl/minimum-version-t tests/perl/strict-t                   \
-       tests/tap/libtap.sh tests/tap/perl/Test/RRA.pm                     \
-       tests/tap/perl/Test/RRA/Config.pm                                  \
-       tests/tap/perl/Test/RRA/Automake.pm tests/tools/heimdal-history-t  \
-       tests/tools/heimdal-strength-t tests/tools/wordlist-cdb-t          \
-       tests/tools/wordlist-sqlite-t tests/tools/wordlist-t               \
+EXTRA_DIST = .gitignore .travis.yml README.md LICENSE bootstrap                    \
+       cracklib/HISTORY cracklib/LICENCE cracklib/README                   \
+       cracklib/genrules.pl cracklib/mkdict docs/krb5-strength.5.in        \
+       docs/krb5-strength.pod docs/metadata tests/README tests/TESTS       \
+       tests/data/krb5.conf tests/data/make-krb5-conf tests/data/passwords \
+       tests/data/perl.conf tests/data/perlcriticrc tests/data/perltidyrc  \
+       tests/data/valgrind.supp tests/data/wordlist                        \
+       tests/data/wordlist.cdb tests/data/wordlist.sqlite                  \
+       tests/docs/pod-spelling-t tests/docs/pod-t tests/docs/urls-t        \
+       tests/perl/critic-t tests/perl/minimum-version-t                    \
+       tests/perl/strict-t tests/tap/libtap.sh tests/tap/perl/Test/RRA.pm  \
+       tests/tap/perl/Test/RRA/Config.pm                                   \
+       tests/tap/perl/Test/RRA/Automake.pm tests/tools/heimdal-history-t   \
+       tests/tools/heimdal-strength-t tests/tools/wordlist-cdb-t           \
+       tests/tools/wordlist-sqlite-t tests/tools/wordlist-t                \
        tests/util/xmalloc-t tools/heimdal-strength.pod
 
 
@@ -644,43 +677,26 @@ dist_bin_SCRIPTS = tools/heimdal-history tools/krb5-strength-wordlist
 dist_man_MANS = tools/heimdal-history.1 tools/heimdal-strength.1 \
        tools/krb5-strength-wordlist.1
 
+man_MANS = docs/krb5-strength.5
 
 # Handle the standard stuff that make maintainer-clean should probably remove
 # but doesn't.  This breaks the GNU coding standard, but in this area the GNU
 # coding standard is dumb.
-CLEANFILES = tests/data/dictionary.hwm tests/data/dictionary.pwd \
-       tests/data/dictionary.pwi
+CLEANFILES = docs/krb5-strength.5 tests/data/dictionary.hwm \
+       tests/data/dictionary.pwd tests/data/dictionary.pwi
 
 DISTCLEANFILES = tests/data/.placeholder
-MAINTAINERCLEANFILES = Makefile.in aclocal.m4 build-aux/compile                 \
-       build-aux/config.guess build-aux/config.sub build-aux/depcomp    \
-       build-aux/install-sh build-aux/ltmain.sh build-aux/missing       \
-       config.h.in config.h.in~ configure m4/libtool.m4 m4/ltoptions.m4 \
-       m4/ltsugar.m4 m4/ltversion.m4 m4/lt~obsolete.m4                  \
-       tests/data/wordlist.cdb tests/data/wordlist.sqlite               \
-       tools/heimdal-history.1 tools/heimdal-strength.1                 \
-       tools/krb5-strength-wordlist.1
-
-
-# A set of flags for warnings.  Add -O because gcc won't find some warnings
-# without optimization turned on.  Desirable warnings that can't be turned
-# on due to other problems:
-#
-#     -Wconversion      http://bugs.debian.org/488884 (htons warnings)
-#
-# Last checked against gcc 4.7.2 (2013-04-22).  -D_FORTIFY_SOURCE=2 enables
-# warn_unused_result attribute markings on glibc functions on Linux, which
-# catches a few more issues.
-WARNINGS = -g -O -D_FORTIFY_SOURCE=2 -Wall -Wextra -Wendif-labels         \
-       -Wformat=2 -Winit-self -Wswitch-enum -Wuninitialized -Wfloat-equal \
-       -Wdeclaration-after-statement -Wshadow -Wpointer-arith             \
-       -Wbad-function-cast -Wcast-align -Wwrite-strings                   \
-       -Wjump-misses-init -Wlogical-op -Wstrict-prototypes                \
-       -Wold-style-definition -Wmissing-prototypes -Wnormalized=nfc       \
-       -Wpacked -Wredundant-decls -Wnested-externs -Winline -Wvla -Werror
-
-tests_runtests_CPPFLAGS = -DSOURCE='"$(abs_top_srcdir)/tests"' \
-       -DBUILD='"$(abs_top_builddir)/tests"'
+MAINTAINERCLEANFILES = Makefile.in aclocal.m4 build-aux/compile                \
+       build-aux/config.guess build-aux/config.sub build-aux/depcomp   \
+       build-aux/install-sh build-aux/ltmain.sh build-aux/missing      \
+       config.h.in config.h.in~ configure docs/krb5-strength.5.in      \
+       m4/libtool.m4 m4/ltoptions.m4 m4/ltsugar.m4 m4/ltversion.m4     \
+       m4/lt~obsolete.m4 tests/data/wordlist.cdb                       \
+       tests/data/wordlist.sqlite tools/heimdal-history.1              \
+       tools/heimdal-strength.1 tools/krb5-strength-wordlist.1
+
+tests_runtests_CPPFLAGS = -DC_TAP_SOURCE='"$(abs_top_srcdir)/tests"' \
+       -DC_TAP_BUILD='"$(abs_top_builddir)/tests"'
 
 check_LIBRARIES = tests/tap/libtap.a
 tests_tap_libtap_a_CPPFLAGS = -I$(abs_top_srcdir)/tests $(KRB5_CPPFLAGS)
@@ -707,6 +723,12 @@ tests_portable_mkstemp_t_SOURCES = tests/portable/mkstemp-t.c \
        tests/portable/mkstemp.c
 
 tests_portable_mkstemp_t_LDADD = tests/tap/libtap.a portable/libportable.la
+tests_portable_reallocarray_t_SOURCES = tests/portable/reallocarray-t.c \
+       tests/portable/reallocarray.c
+
+tests_portable_reallocarray_t_LDADD = tests/tap/libtap.a \
+       portable/libportable.la
+
 tests_portable_snprintf_t_SOURCES = tests/portable/snprintf-t.c \
        tests/portable/snprintf.c
 
@@ -742,7 +764,6 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am  $(am__confi
        echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign Makefile'; \
        $(am__cd) $(top_srcdir) && \
          $(AUTOMAKE) --foreign Makefile
-.PRECIOUS: Makefile
 Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
        @case '$?' in \
          *config.status*) \
@@ -1027,6 +1048,15 @@ tests/portable/mkstemp.$(OBJEXT): tests/portable/$(am__dirstamp) \
 tests/portable/mkstemp-t$(EXEEXT): $(tests_portable_mkstemp_t_OBJECTS) $(tests_portable_mkstemp_t_DEPENDENCIES) $(EXTRA_tests_portable_mkstemp_t_DEPENDENCIES) tests/portable/$(am__dirstamp)
        @rm -f tests/portable/mkstemp-t$(EXEEXT)
        $(AM_V_CCLD)$(LINK) $(tests_portable_mkstemp_t_OBJECTS) $(tests_portable_mkstemp_t_LDADD) $(LIBS)
+tests/portable/reallocarray-t.$(OBJEXT):  \
+       tests/portable/$(am__dirstamp) \
+       tests/portable/$(DEPDIR)/$(am__dirstamp)
+tests/portable/reallocarray.$(OBJEXT): tests/portable/$(am__dirstamp) \
+       tests/portable/$(DEPDIR)/$(am__dirstamp)
+
+tests/portable/reallocarray-t$(EXEEXT): $(tests_portable_reallocarray_t_OBJECTS) $(tests_portable_reallocarray_t_DEPENDENCIES) $(EXTRA_tests_portable_reallocarray_t_DEPENDENCIES) tests/portable/$(am__dirstamp)
+       @rm -f tests/portable/reallocarray-t$(EXEEXT)
+       $(AM_V_CCLD)$(LINK) $(tests_portable_reallocarray_t_OBJECTS) $(tests_portable_reallocarray_t_LDADD) $(LIBS)
 tests/portable/snprintf-t.$(OBJEXT): tests/portable/$(am__dirstamp) \
        tests/portable/$(DEPDIR)/$(am__dirstamp)
 tests/portable/snprintf.$(OBJEXT): tests/portable/$(am__dirstamp) \
@@ -1193,6 +1223,7 @@ distclean-compile:
 @AMDEP_TRUE@@am__include@ @am__quote@portable/$(DEPDIR)/dummy.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@portable/$(DEPDIR)/krb5-extra.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@portable/$(DEPDIR)/mkstemp.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@portable/$(DEPDIR)/reallocarray.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@portable/$(DEPDIR)/snprintf.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@portable/$(DEPDIR)/strndup.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@tests/$(DEPDIR)/tests_runtests-runtests.Po@am__quote@
@@ -1202,6 +1233,8 @@ distclean-compile:
 @AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/asprintf.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/mkstemp-t.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/mkstemp.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/reallocarray-t.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/reallocarray.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/snprintf-t.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/snprintf.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@tests/portable/$(DEPDIR)/strndup-t.Po@am__quote@
@@ -1524,10 +1557,10 @@ clean-libtool:
 
 distclean-libtool:
        -rm -f libtool config.lt
-install-man1: $(dist_man_MANS)
+install-man1: $(dist_man_MANS) $(man_MANS)
        @$(NORMAL_INSTALL)
        @list1=''; \
-       list2='$(dist_man_MANS)'; \
+       list2='$(dist_man_MANS) $(man_MANS)'; \
        test -n "$(man1dir)" \
          && test -n "`echo $$list1$$list2`" \
          || exit 0; \
@@ -1562,11 +1595,54 @@ uninstall-man1:
        @$(NORMAL_UNINSTALL)
        @list=''; test -n "$(man1dir)" || exit 0; \
        files=`{ for i in $$list; do echo "$$i"; done; \
-       l2='$(dist_man_MANS)'; for i in $$l2; do echo "$$i"; done | \
+       l2='$(dist_man_MANS) $(man_MANS)'; for i in $$l2; do echo "$$i"; done | \
          sed -n '/\.1[a-z]*$$/p'; \
        } | sed -e 's,.*/,,;h;s,.*\.,,;s,^[^1][0-9a-z]*$$,1,;x' \
              -e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
        dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
+install-man5: $(dist_man_MANS) $(man_MANS)
+       @$(NORMAL_INSTALL)
+       @list1=''; \
+       list2='$(dist_man_MANS) $(man_MANS)'; \
+       test -n "$(man5dir)" \
+         && test -n "`echo $$list1$$list2`" \
+         || exit 0; \
+       echo " $(MKDIR_P) '$(DESTDIR)$(man5dir)'"; \
+       $(MKDIR_P) "$(DESTDIR)$(man5dir)" || exit 1; \
+       { for i in $$list1; do echo "$$i"; done;  \
+       if test -n "$$list2"; then \
+         for i in $$list2; do echo "$$i"; done \
+           | sed -n '/\.5[a-z]*$$/p'; \
+       fi; \
+       } | while read p; do \
+         if test -f $$p; then d=; else d="$(srcdir)/"; fi; \
+         echo "$$d$$p"; echo "$$p"; \
+       done | \
+       sed -e 'n;s,.*/,,;p;h;s,.*\.,,;s,^[^5][0-9a-z]*$$,5,;x' \
+             -e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,' | \
+       sed 'N;N;s,\n, ,g' | { \
+       list=; while read file base inst; do \
+         if test "$$base" = "$$inst"; then list="$$list $$file"; else \
+           echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man5dir)/$$inst'"; \
+           $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man5dir)/$$inst" || exit $$?; \
+         fi; \
+       done; \
+       for i in $$list; do echo "$$i"; done | $(am__base_list) | \
+       while read files; do \
+         test -z "$$files" || { \
+           echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(man5dir)'"; \
+           $(INSTALL_DATA) $$files "$(DESTDIR)$(man5dir)" || exit $$?; }; \
+       done; }
+
+uninstall-man5:
+       @$(NORMAL_UNINSTALL)
+       @list=''; test -n "$(man5dir)" || exit 0; \
+       files=`{ for i in $$list; do echo "$$i"; done; \
+       l2='$(dist_man_MANS) $(man_MANS)'; for i in $$l2; do echo "$$i"; done | \
+         sed -n '/\.5[a-z]*$$/p'; \
+       } | sed -e 's,.*/,,;h;s,.*\.,,;s,^[^5][0-9a-z]*$$,5,;x' \
+             -e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
+       dir='$(DESTDIR)$(man5dir)'; $(am__uninstall_files_from_dir)
 
 ID: $(am__tagged_files)
        $(am__define_uniq_tagged_files); mkid -fID $$unique
@@ -1688,15 +1764,15 @@ dist-xz: distdir
        $(am__post_remove_distdir)
 
 dist-tarZ: distdir
-       @echo WARNING: "Support for shar distribution archives is" \
-                      "deprecated." >&2
+       @echo WARNING: "Support for distribution archives compressed with" \
+                      "legacy program 'compress' is deprecated." >&2
        @echo WARNING: "It will be removed altogether in Automake 2.0" >&2
        tardir=$(distdir) && $(am__tar) | compress -c >$(distdir).tar.Z
        $(am__post_remove_distdir)
 
 dist-shar: distdir
-       @echo WARNING: "Support for distribution archives compressed with" \
-                      "legacy program 'compress' is deprecated." >&2
+       @echo WARNING: "Support for shar distribution archives is" \
+                      "deprecated." >&2
        @echo WARNING: "It will be removed altogether in Automake 2.0" >&2
        shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
        $(am__post_remove_distdir)
@@ -1732,17 +1808,17 @@ distcheck: dist
        esac
        chmod -R a-w $(distdir)
        chmod u+w $(distdir)
-       mkdir $(distdir)/_build $(distdir)/_inst
+       mkdir $(distdir)/_build $(distdir)/_build/sub $(distdir)/_inst
        chmod a-w $(distdir)
        test -d $(distdir)/_build || exit 0; \
        dc_install_base=`$(am__cd) $(distdir)/_inst && pwd | sed -e 's,^[^:\\/]:[\\/],/,'` \
          && dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
          && am__cwd=`pwd` \
-         && $(am__cd) $(distdir)/_build \
-         && ../configure \
+         && $(am__cd) $(distdir)/_build/sub \
+         && ../../configure \
            $(AM_DISTCHECK_CONFIGURE_FLAGS) \
            $(DISTCHECK_CONFIGURE_FLAGS) \
-           --srcdir=.. --prefix="$$dc_install_base" \
+           --srcdir=../.. --prefix="$$dc_install_base" \
          && $(MAKE) $(AM_MAKEFLAGS) \
          && $(MAKE) $(AM_MAKEFLAGS) dvi \
          && $(MAKE) $(AM_MAKEFLAGS) check \
@@ -1802,7 +1878,7 @@ check: check-am
 all-am: Makefile $(LIBRARIES) $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS) \
                $(MANS) config.h
 installdirs:
-       for dir in "$(DESTDIR)$(moduledir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"; do \
+       for dir in "$(DESTDIR)$(moduledir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(man5dir)"; do \
          test -z "$$dir" || $(MKDIR_P) "$$dir"; \
        done
 install: install-am
@@ -1901,7 +1977,7 @@ install-info: install-info-am
 
 install-info-am:
 
-install-man: install-man1
+install-man: install-man1 install-man5
 
 install-pdf: install-pdf-am
 
@@ -1937,7 +2013,7 @@ ps-am:
 uninstall-am: uninstall-binPROGRAMS uninstall-dist_binSCRIPTS \
        uninstall-man uninstall-moduleLTLIBRARIES
 
-uninstall-man: uninstall-man1
+uninstall-man: uninstall-man1 uninstall-man5
 
 .MAKE: all check-am install-am install-strip
 
@@ -1955,15 +2031,24 @@ uninstall-man: uninstall-man1
        install-data-am install-dist_binSCRIPTS install-dvi \
        install-dvi-am install-exec install-exec-am install-html \
        install-html-am install-info install-info-am install-man \
-       install-man1 install-moduleLTLIBRARIES install-pdf \
-       install-pdf-am install-ps install-ps-am install-strip \
-       installcheck installcheck-am installdirs maintainer-clean \
-       maintainer-clean-generic maintainer-clean-local mostlyclean \
-       mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
-       pdf pdf-am ps ps-am tags tags-am uninstall uninstall-am \
-       uninstall-binPROGRAMS uninstall-dist_binSCRIPTS uninstall-man \
-       uninstall-man1 uninstall-moduleLTLIBRARIES
+       install-man1 install-man5 install-moduleLTLIBRARIES \
+       install-pdf install-pdf-am install-ps install-ps-am \
+       install-strip installcheck installcheck-am installdirs \
+       maintainer-clean maintainer-clean-generic \
+       maintainer-clean-local mostlyclean mostlyclean-compile \
+       mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
+       tags tags-am uninstall uninstall-am uninstall-binPROGRAMS \
+       uninstall-dist_binSCRIPTS uninstall-man uninstall-man1 \
+       uninstall-man5 uninstall-moduleLTLIBRARIES
+
+.PRECIOUS: Makefile
+
 
+# Substitute the installation paths into the manual page.
+docs/krb5-strength.5: $(srcdir)/docs/krb5-strength.5.in
+       [ -d docs ] || mkdir docs
+       sed -e 's%\(\\f(CI\)*\@moduledir\(\\fI\)*\@%$(moduledir)%' \
+           < $(srcdir)/docs/krb5-strength.5.in > $@
 
 # Also remove the generated *.c files from our JSON test data on
 # maintainer-clean.
@@ -1971,8 +2056,10 @@ maintainer-clean-local:
        rm -f tests/data/passwords/*.c
 
 warnings:
-       $(MAKE) V=0 CFLAGS='$(WARNINGS)'
-       $(MAKE) V=0 CFLAGS='$(WARNINGS)' $(check_PROGRAMS)
+       $(MAKE) V=0 CFLAGS='$(WARNINGS_CFLAGS) $(AM_CFLAGS)' \
+           KRB5_CPPFLAGS='$(KRB5_CPPFLAGS_GCC)'
+       $(MAKE) V=0 CFLAGS='$(WARNINGS_CFLAGS) $(AM_CFLAGS)' \
+           KRB5_CPPFLAGS='$(KRB5_CPPFLAGS_GCC)' $(check_PROGRAMS)
 
 # The dictionary is used by the tests and needs to be built first.
 @EMBEDDED_CRACKLIB_TRUE@tests/data/dictionary.pwd: cracklib/packer $(srcdir)/cracklib/mkdict \