]> eyrie.org Git - kerberos/krb5-strength.git/blobdiff - Makefile.am
Merge branch 'debian' into squeeze
[kerberos/krb5-strength.git] / Makefile.am
index 7fce813f27e3739b85287d3e72ce8647aa477047..7d8c5c9301d23fe4201f9c7e2e7a250661b1993a 100644 (file)
@@ -19,13 +19,16 @@ EXTRA_DIST = .gitignore LICENSE autogen cracklib/HISTORY cracklib/LICENCE  \
        tests/tap/perl/Test/RRA/Config.pm                                  \
        tests/tap/perl/Test/RRA/Automake.pm tests/tools/heimdal-history-t  \
        tests/tools/heimdal-strength-t tests/tools/wordlist-cdb-t          \
+       tests/tools/wordlist-sqlite-t tests/tools/wordlist-t               \
        tests/util/xmalloc-t tools/heimdal-strength.pod
 
 # Do this globally.  Everything needs to find the Kerberos headers and
-# libraries, and if we're using the system CrackLib or libcdb, add its
-# location unconditionally as well.
-AM_CPPFLAGS = $(CRACKLIB_CPPFLAGS) $(KRB5_CPPFLAGS) $(CDB_CPPFLAGS)
-AM_LDFLAGS = $(CRACKLIB_LDFLAGS) $(KRB5_LDFLAGS) $(CDB_LDFLAGS)
+# libraries, and if we're using the system CrackLib, TinyCDB, or SQLite, add
+# its location unconditionally as well.
+AM_CPPFLAGS = $(CRACKLIB_CPPFLAGS) $(KRB5_CPPFLAGS) $(CDB_CPPFLAGS) \
+       $(SQLITE_CPPFLAGS)
+AM_LDFLAGS = $(CRACKLIB_LDFLAGS) $(KRB5_LDFLAGS) $(CDB_LDFLAGS) \
+       $(SQLITE_LDFLAGS)
 
 # Build our portability library.
 noinst_LTLIBRARIES = portable/libportable.la
@@ -58,29 +61,31 @@ moduledir = $(libdir)/krb5/plugins/pwqual
 module_LTLIBRARIES = plugin/strength.la
 plugin_strength_la_SOURCES = plugin/cdb.c plugin/classes.c plugin/config.c \
        plugin/cracklib.c plugin/error.c plugin/general.c plugin/heimdal.c \
-       plugin/internal.h plugin/mit.c plugin/principal.c plugin/vector.c
+       plugin/internal.h plugin/mit.c plugin/principal.c plugin/sqlite.c  \
+       plugin/vector.c
 plugin_strength_la_LDFLAGS = -module -avoid-version
 if EMBEDDED_CRACKLIB
     plugin_strength_la_LIBADD = cracklib/libcracklib.la
 else
     plugin_strength_la_LIBADD = $(CRACKLIB_LIBS)
 endif
-plugin_strength_la_LIBADD += portable/libportable.la $(KRB5_LIBS) $(CDB_LIBS)
+plugin_strength_la_LIBADD += portable/libportable.la $(KRB5_LIBS) \
+       $(CDB_LIBS) $(SQLITE_LIBS)
 
 # The Heimdal external check program.
 bin_PROGRAMS = tools/heimdal-strength
 tools_heimdal_strength_CFLAGS = $(AM_CFLAGS)
 tools_heimdal_strength_SOURCES = plugin/cdb.c plugin/classes.c           \
        plugin/config.c plugin/cracklib.c plugin/error.c plugin/general.c \
-       plugin/internal.h plugin/principal.c plugin/vector.c              \
-       tools/heimdal-strength.c
+       plugin/internal.h plugin/principal.c plugin/sqlite.c              \
+       plugin/vector.c tools/heimdal-strength.c
 if EMBEDDED_CRACKLIB
     tools_heimdal_strength_LDADD = cracklib/libcracklib.la
 else
     tools_heimdal_strength_LDADD = $(CRACKLIB_LIBS)
 endif
 tools_heimdal_strength_LDADD += util/libutil.a portable/libportable.la \
-       $(KRB5_LIBS) $(CDB_LIBS)
+       $(KRB5_LIBS) $(CDB_LIBS) $(SQLITE_LIBS)
 
 # Other tools.
 dist_bin_SCRIPTS = tools/heimdal-history tools/krb5-strength-wordlist
@@ -192,14 +197,14 @@ check-local: $(check_PROGRAMS) tests/data/dictionary.pwd
 # Used by maintainers to run the main test suite under valgrind.  Suppress
 # the xmalloc and pod-spelling tests because the former won't work properly
 # under valgrind (due to increased memory usage) and the latter is pointless
-# to run under valgrind.  Don't try to trace the test for
-# krb5-strength-wordlist, since it's pure Perl.
+# to run under valgrind.  Don't try to trace several of the tests that are
+# written in Perl or shell and test Perl programs.
 check-valgrind: $(check_PROGRAMS) tests/data/dictionary.pwd
        rm -rf $(abs_top_builddir)/tmp-valgrind
        mkdir $(abs_top_builddir)/tmp-valgrind
-       env RRA_MAINTAINER_TESTS= valgrind --leak-check=full    \
-           --show-reachable=yes --trace-children=yes           \
-           --log-file=$(abs_top_builddir)/tmp-valgrind/log.%p  \
-           --suppressions=tests/data/valgrind.supp             \
-           --trace-children-skip="/bin/sh,*/cat,*/diff,*/expr,*/grep,*/mkdir,*/rm,*/rmdir,*/sed,*/sleep,*/true,*/wc,*/docs/*-t,*/perl/*-t,*/data/make-krb5-conf,*/tools/wordlist-*-t" \
+       env RRA_MAINTAINER_TESTS= valgrind --leak-check=full            \
+           --show-reachable=yes --trace-children=yes                   \
+           --log-file=$(abs_top_builddir)/tmp-valgrind/log.%p          \
+           --suppressions=$(abs_top_srcdir)/tests/data/valgrind.supp   \
+           --trace-children-skip="/bin/sh,*/cat,*/diff,*/expr,*/grep,*/mkdir,*/rm,*/rmdir,*/sed,*/sleep,*/true,*/wc,*/docs/*-t,*/perl/*-t,*/data/make-krb5-conf,*/tools/heimdal-history-t,*/tools/wordlist*-t" \
            tests/runtests -l '$(abs_top_srcdir)/tests/TESTS'