]> eyrie.org Git - kerberos/krb5-strength.git/blob - krb5-strength.spec
Update DocKnot configuration
[kerberos/krb5-strength.git] / krb5-strength.spec
1 %bcond_with     krb5            # build with MIT kerberos if asked
2
3 # Crypt::PBKDF2 isn't in base or EPEL on rhel8 so this won't work there frex
4 %bcond_with     history # build heimdal-history tool
5
6 Name:           krb5-strength
7 Version:        3.3
8 Release:        1%{?dist}
9 Summary:        Kerberos password strength checking plugin
10 Group:          System Environment/Daemons
11 License:        MIT
12 Vendor:         Russ Allbery
13 URL:            https://www.eyrie.org/~eagle/software/%{name}/
14 Source0:        https://archives.eyrie.org/software/kerberos/%{name}-%{version}.tar.gz
15
16 %if %{with krb5}
17 BuildRequires: krb5-devel
18 %else
19 BuildRequires: heimdal-devel
20 BuildRequires: libcom_err-devel
21 BuildRequires: ncurses-devel
22 %endif
23 BuildRequires: sqlite-devel
24 BuildRequires: tinycdb-devel
25
26 Requires: perl(autodie)
27 Requires: perl(Getopt::Long)
28 Requires: sqlite
29 Requires: tinycdb
30 %if %{with krb5}
31 Requires: krb5-server
32 %else
33 Requires: heimdal-server
34 %endif
35 %if %{with history}
36 %package -n %{name}-history
37 Summary:        Kerberos password strength checking plugin history tool
38 Group:          System Environment/Daemons
39 Requires: %{name}
40 Requires: perl(autodie)
41 Requires: perl(Const::Fast)
42 Requires: perl(Crypt::PBKDF2)
43 Requires: perl(DB_File::Lock)
44 Requires: perl(Getopt::Long::Descriptive)
45 Requires: perl(IPC::Run)
46 Requires: perl(JSON::MaybeXS)
47 %description -n %{name}-history
48 Heimdal password history tool for Kerberos password strength checking plugin
49 %endif
50
51 %description
52 Kerberos password strength checking plugin and program for Heimdal KDC
53
54 %prep
55 %setup -q
56
57 # in theory a system could have Heimdal and krb5
58 %build 
59 %if %{with krb5}
60 export PATH_KRB5_CONFIG=/usr/bin/krb5-config
61 %else
62 export PATH_KRB5_CONFIG=/usr/bin/heimdal-krb5-config
63 %endif
64 %configure
65 %make_build
66
67 %install
68 %make_install
69 %if !%{with history}
70 rm -f $RPM_BUILD_ROOT%{_bindir}/heimdal-history
71 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/heimdal-history.*
72 %endif
73
74 %files
75 %defattr(-,root,root)
76 %license LICENSE
77 %doc README
78 %{_bindir}/heimdal-strength
79 %{_bindir}/krb5-strength-wordlist
80 %{_mandir}/man1/heimdal-strength.*
81 %{_mandir}/man1/krb5-strength-wordlist.*
82 %{_mandir}/man5
83 %{_libdir}/krb5/plugins/pwqual/strength.so
84 %{_libdir}/krb5/plugins/pwqual/strength.la
85
86 %if %{with history}
87 %files -n %{name}-history
88 %defattr(-,root,root)
89 %{_bindir}/heimdal-history
90 %{_mandir}/man1/heimdal-history.*
91 %endif
92
93 %changelog
94 * Mon Dec 25 2023 Russ Allbery <eagle@eyrie.org> 3.3-1
95 - Update license
96 - Update Perl dependencies for history package
97
98 * Wed Nov 15 2023 Daria Phoebe Brashear <dariaphoebe@auristor.com> 3.2-1
99 - Heimdal spec file